Модуль для Автозаполнения ЧПУ - SEO URL для Opencart 2

Модуль генерирует ЧПУ - SEO URL в атоматическом режиме на лету на основе названия с транслитерацией на латинские буквы и с фильтрацией запрещенных символов.

Модуль работает в:

  1. Товарах
  2. Категориях
  3. Производителях
  4. Страниц
  5. Блога
  6. Новостей

Модуль легко адаптируется под другие модули


Установка модуля:

  1. Распаковать архив
  2. Установить модификатор через Установку модификаций в административной части модуля
  3. Обновить модификаторы
Совместимость с версиями
Opencart 2.0
Opencart 2.1
Opencart 2.2
Opencart 2.3
Развернуть
Свернуть
    Что такое ошибка 500? Это ошибка в коде php вашего сайта. Чтоб ее расшифровать и усранить - нужно:
  1. В административной части сайта перейти в Система->Инструменты->Лог ошибок. В конце будут актуальные ошибки сайта. Если ошибки там не присутствуют - нужно включить запись ошибок, для этого нужно перейти Система->Настройки->Сервер->Записывать ошибки->Да
  2. Если есть доступ по FTP то вы можете открыть файл logs/error.log у вас на сервере. Последние ошибки - будут соответствовать ошибкам вашего сайта.
  3. Если на сайте не отображается ошибка - можно отобразить их через Ваш htaccess(лежит в корне сайта). Нужно в самом начале дописать следующий код.

    php_value display_errors 1

    php_value display_startup_errors 1

    php_value error_reporting E_ALL

    Если при установке модуля вы получаете данную ошибку то нужно сделать следующее:
  1. Вы можете установить FTP QuickFix модификацию localcopy.ocmod.xml, которая позволяет устанавливать модули без настройки FTP на вашем сайте.
  2. Можно настроить доступы FTP. Нужно зайти в Система > Настройки > FTP.
  1. Скачайте и установите модификатор localcopy.ocmod.xml
  2. Обновите модификаторы в админсистративной части сайта
  3. Загрузите модуль еще раз
    Возможные решения:
  1. Если до этого Вы не устанавливали модули через админку сайта, то Вам нужно установить модуль localcopy.ocmod.xml. После этого попробовать переустановить Ваш модуль.
  2. Необходимо дать права на просмотр и изменение настроек модуля - для этого нужно перейти Система->Настройки->Пользователи->Группа пользователей<->Выбрать вашу группу, установить все галочки и нажать сохранить.
  3. Возможно Ваш язык не поддерживается модулем и Вам нужно обратиться в поддержку за доработкой.
  4. У модуля может не быть страницы с настройками.
    Если при входе в модуль вы получаете сообщение "Доступ запрещен! У Вас нет прав для доступа к этой странице. Если она Вам нужна, обратитесь к администратору." бывает несколько причин
  1. Нужно дать права администраторам на управление модулем для этого нужно перейти Система->Настройки->Пользователи->Группа пользователей<->Выбрать вашу группу, установить все галочки и нажать сохранить.
  2. Модуль установился не полностью. Нужно установить модуль localcopy.ocmod.xml и попробовать переустановить модуль.
  3. Версия Модуля может не соответствовать версии Вашего сайта. Сверьте версии сайта и модуля. Если они различаются - то переустановите Модуль.
    Модули для установки с администативной части бывают несольких видов:
  1. Файл модификаций .ocmod.xml - это файл модификаций. Состоит из одного файла. Устанавливаются через Установку модулей.
  2. Архив с модулем. .ocmod.zip - это архив с файлами. Внутри него могут быть файлы install.xml install.php install.sql и папка upload(может быть пуста) других файлов и папок быть не может. Устанавливаются через Установку модулей.
  3. Просто папка Upload - файлы внутри такой папки нужно залить в корень сайта по FTP

Эта ошибка означает что внутри установочного архива отсутствует папка upload. Такие папки должны быть внутри модуля .ocmod.zip и может быть пустой, но является обязательной.

    Если при установке модуля позникает такая ошибка, то вероятно Вы пытаетесь установить модификатор с таким ID который уже есть в базе(установлен).
  1. Перед установкой модуля нужно удалить предыдущую версию данного модуля.
  2. Если такого модуля нет - то вероятно это просто совпадение. Вам нужно открыть файл с расширением xml и поменять параметр <code> на другой уникальный.
    Эта ошибка означает, что вы хостите установить модификатор но он очень большой. Символов в модификаторе не должно быть больчем чем 65535(значение по умолчанию). Есть много вариантов решения проблемы.
  1. Можно разбить модификатор на несолько частей. Нужно оставлять шапку и брать частями модификаторы. Нужно только менять ID модуля в параметре <code>.
  2. Можно изменить Параметры таблицы Базы Данных где хранятся наши модификации. Выполняем запрос в phpmyadmin ALTER TABLE oc_modification CHANGE xml xml MEDIUMTEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL; Если у Вас префикс отличается от oc - замените его на свой.
  3. База данных хоть и является хорошим местом для хранения информации. Но гораздо лучше если файл модификаций копировать через FTP в папку system - это будет равносильно установке если файл имеет формат .ocmod.xml
    Такая ошибка возникает когда установлена не правильная версия модуля.
  1. Для исправления такой ошибки Вам нужно удалить все файлы установленного модуля. Чтоб облегчить себе задачу - Можно вопросльзоваться модулем удаления модулей. Либо открыть архив с модулем - посмотреть какие файлы удалить и стереть их у Вас в файлах Вашего сайта.
  2. Так же модуль может обращаться к Базе Даныых к таблице, которой не существует. Нужно почитать инструкцию к модулю и переустановить.
    Когда на сайте установлен модуль и при нажатии на кнопки и другие части сайта ничего не происходит - возможно произошел конфликт скриптов Java Script
  1. Что бы узнать какая ошибка произошла на сайте - Вам нужно на странице с ошибкой нажать F12 и выбрать вкладку Консоль(console) ошибки будут выделены красным.
  2. Возможно не все модификаторы модуля установились. Нужно в ручном режиме проверить какие строки модификаций установились.

Вроде бы модуль установлен и настроен а все равно не видно его работы.

ВОзможно такой модуль требует вывода На сайте в ручном режиме. Для этого Вам нужно перейти в Дизайн->Макеты и вывести модуль в нужном макете на нужном месте

Некоторые модули вносят изменения в файлы сайта в виде модификаций - не меняя их. После установки таких модулей нужно обязательно обновить модификаторы сайта.

Совместимость с версиями
Opencart 2.0
Opencart 2.1
Opencart 2.2
Opencart 2.3
Это раздел вопросов, комментариев и отзывов! Решением проблем занимается техподдержка
Категория
Категория: Все модули

Цена: Бесплатно

  • Не содержит вирусов
  • Нет привязки к домену
  • Код не закодирован
  • Работоспособность 100%
  • Формат OCMOD
  • Написать в поддержку

Рекомендуемые товары